Bienvenido a la Comunidad UBNT

Es posible recuperar este loco M5??

image
Me conecto con el TTL-USB al puerto serial y le doy corriente al POE esto es lo único que hace.
¿Tiene arreglo?


3.16.0-4-amd64# cu --parity=none -s 115200 -l /dev/ttyUSB0
Connected.


U-Boot 1.1.4.2-s594 (Dec  5 2012 - 15:23:07)

Board not calibrated, cannot determine board type.
Board: Ubiquiti Networks XM board (rev 1.255 ffff)
DRAM:  32 MB
Flash:  8 MB
*** Warning - bad CRC, using default environment

Board not calibrated, cannot determine board type.
PCIe WLAN Module found (#1).


U-Boot 1.1.4.2-s594 (Dec  5 2012 - 15:23:07)

Board not calibrated, cannot determine board type.
Board: Ubiquiti Networks XM board (rev 1.255 ffff)
DRAM:  32 MB
Flash:  8 MB
*** Warning - bad CRC, using default environment

Board not calibrated, cannot determine board type.
PCIe WLAN Module found (#1).


U-Boot 1.1.4.2-s594 (Dec  5 2012 - 15:23:07)

Board not calibrated, cannot determine board type.
Board: Ubiquiti Networks XM board (rev 1.255 ffff)
DRAM:  32 MB
Flash:  8 MB
*** Warning - bad CRC, using default environment

Board not calibrated, cannot determine board type.
PCIe WLAN Module found (#1).


U-Boot 1.1.4.2-s594 (Dec  5 2012 - 15:23:07)

Board not calibrated, cannot determine board type.
Board: Ubiquiti Networks XM board (rev 1.255 ffff)
DRAM:  32 MB
Flash:  8 MB
*** Warning - bad CRC, using default environment

Board not calibrated, cannot determine board type.
PCIe WLAN Module found (#1).
Etiquetado:

Comentarios

  • El trasto tiene muchas dificultades para entrar en modo rescate, (reset+power), y cuando por fin responde al ping y se activa el servidor ftp, no se traga el firmware
    Se intenta con:


    3.16.0-4-amd64#  tftp 192.168.1.20
    tftp> bin
    tftp> trace
    Packet tracing on.
    tftp> put XM.v5.5.11.28002.150723.1344.bin
    sent WRQ <file=XM.v5.5.11.28002.150723.1344.bin, mode=octet>
    sent WRQ <file=XM.v5.5.11.28002.150723.1344.bin, mode=octet>
    sent WRQ <file=XM.v5.5.11.28002.150723.1344.bin, mode=octet>
    sent WRQ <file=XM.v5.5.11.28002.150723.1344.bin, mode=octet>
    sent WRQ <file=XM.v5.5.11.28002.150723.1344.bin, mode=octet>
    Transfer timed out.

    tftp> quit

    Y con:

    3.16.0-4-amd64#  tftp 192.168.1.20
    tftp> bin
    tftp> trace
    Packet tracing on.
    put XM.v5.5.11.28002.150723.1344.bin flash_update
    sent WRQ <file=XM.v5.5.11.28002.150723.1344.bin, mode=octet>
    sent WRQ <file=XM.v5.5.11.28002.150723.1344.bin, mode=octet>
    sent WRQ <file=XM.v5.5.11.28002.150723.1344.bin, mode=octet>
    sent WRQ <file=XM.v5.5.11.28002.150723.1344.bin, mode=octet>
    sent WRQ <file=XM.v5.5.11.28002.150723.1344.bin, mode=octet>
    Transfer timed out.

    tftp> quit


    Esta es la lectura del puerto serial:


    3.16.0-4-amd64#
    3.16.0-4-amd64#cu --parity=none -s 115200 -l /dev/ttyUSB0
    Connected.


    U-Boot 1.1.4.2-s594 (Dec  5 2012 - 15:23:07)

    Board not calibrated, cannot determine board type.
    Board: Ubiquiti Networks XM board (rev 1.255 ffff)
    DRAM:  32 MB
    Flash:  8 MB
    *** Warning - bad CRC, using default environment

    Board not calibrated, cannot determine board type.
    PCIe WLAN Module found (#1).
    Net:  

    U-Boot 1.1.4.2-s594 (Dec  5 2012 - 15:23:07)

    Board not calibrated, cannot determine board type.
    Board: Ubiquiti Networks XM board (rev 1.255 ffff)
    DRAM:  32 MB
    Flash:  8 MB
    *** Warning - bad CRC, using default environment

    Board not calibrated, cannot determine board type.
    PCIe WLAN Module found (#1).
    Net:   eth0, eth1
    Hit any key to stop autoboot:  0
    Setting default IP 192.168.1.20
    Starting TFTP server...
    Using eth0 (192.168.1.20), address: 0x81000000
    Will reset device configuration (Reset button active after 10 seconds).
    mtdparts variable not set, see 'help mtdparts'
    find_mtd_part
    Warning: partition cfg not found on flash memory! Skipped.
    Waiting for connection: |
    Abort
    Ctrl+c para entrar al interprete de comandos
    ar7240>
    ar7240>
    ar7240> help mtdparts
    mtdparts
        - list partition table
    mtdparts delall
        - delete all partitions
    mtdparts del part-id
        - delete partition (e.g. part-id = nand0,1)
    mtdparts add <mtd-dev> <size>[@<;offset>] [<name>] [ro]
        - add partition
    mtdparts default
        - reset partition table to defaults

    -----

    this command uses three environment variables:

    'partition' - keeps current partition identifier

    partition  := <part-id>
    <part-id>  := <dev-id>,part_num

    'mtdids' - linux kernel mtd device id <-> u-boot device id mapping

    mtdids=<idmap>[,<idmap>,...]

    <idmap>    := <dev-id>=<mtd-id>
    <dev-id>   := 'nand'|'nor'<dev-num>
    <dev-num>  := mtd device number, 0...
    <mtd-id>   := unique device tag used by linux kernel to find mtd device (mtd->name)

    'mtdparts' - partition list

    mtdparts=mtdparts=<mtd-def>[;<mtd-def>...]

    <mtd-def>  := <mtd-id>:<part-def>[,<part-def>...]
    <mtd-id>   := unique device tag used by linux kernel to find mtd device (mtd->name)
    <part-def> := <size>[@<;offset>][<name>][<ro-flag>]
    <size>     := standard linux memsize OR '-' to denote all remaining space
    <offset>   := partition start offset within the device
    <name>     := '(' NAME ')'
    <ro-flag>  := when set to 'ro' makes partition read-only (not used, passed to kernel)

    ar7240> mtdparts
    mtdparts variable not set, see 'help mtdparts'
    no partitions defined

    defaults:
    mtdids  : nor0=ar7240-nor0
    mtdparts: mtdparts=ar7240-nor0:256k(u-boot),64k(u-boot-env),1024k(kernel),6528k(rootfs),256k(cfg),64k(EEPROM)
    ar7240>
    ar7240> ?
    ?       - alias for 'help'
    base    - print or set address offset
    boot    - boot default, i.e., run 'bootcmd'
    bootd   - boot default, i.e., run 'bootcmd'
    bootelf - Boot from an ELF image in memory
    bootm   - boot application image from memory
    cmp     - memory compare
    cp      - memory copy
    crc32   - checksum calculation
    echo    - echo args to console
    erase   - erase FLASH memory
    flinfo  - print FLASH memory information
    go      - start application at address 'addr'
    help    - print online help
    iminfo  - print header information for application image
    imls    - list all images found in flash
    loop    - infinite loop on address range
    md      - memory display
    mii     - MII utility commands
    mm      - memory modify (auto-incrementing)
    mtdparts- define flash/nand partitions
    mtest   - simple RAM test
    mw      - memory write (fill)
    nm      - memory modify (constant address)
    ping    - send ICMP ECHO_REQUEST to network host
    printenv- print environment variables
    protect - enable or disable FLASH write protection
    reset   - Perform RESET of the CPU
    run     - run commands in an environment variable
    saveenv - save environment variables to persistent storage
    setenv  - set environment variables
    sleep   - delay execution for some time
    tftpboot- boot image via network using TFTP protocol
    urescue    - start TFTP server and wait for firmware
    version - print monitor version
    autoscr - run script from memory
    ar7240> ping 8.8.8.8
    Using eth0 device

    Abort
    ping failed; host 8.8.8.8 is not alive
    ar7240>
    Aquí se me escapó un Ctrl+c y me desconecté sin querer.
    Ahora solo falta poner orden en las particiones y hacer sitio para el firmware
    .
  • Hola, tengo un nanostation m5 que se reinicia, conecte via serial al jp1 y en putty de detalla esto:


    U-Boot 1.1.4.2-s445 (Sep  6 2010 - 14:46:33)

    Board: Ubiquiti Networks XM board (rev 0.0 e005)
    DRAM:  32 MB
    Flash:  8 MB
    Net:   eth0, eth1
    Hit any key to stop autoboot:  0
    ## Booting image at 9f050000 ...
       Image Name:   MIPS Ubiquiti Linux-2.6.32.68
       Created:      2015-11-30  15:50:17 UTC
       Image Type:   MIPS Linux Kernel Image (lzma compressed)
       Data Size:    1005326 Bytes = 981.8 kB
       Load Address: 80002000
       Entry Point:  80002000
       Verifying Checksum ... OK
       Uncompressing Kernel Image ... OK

    Starting kernel ...

    Booting...
    ...mounts done
    ...filesystem init done
    ...base ok
    ...update ok
    ...symlinks ok
    ...detect ok
    ...caldata ok
    ...httpd ok
    Fixup ... Done.
    Plugin: system ... Done.
    Plugin: syslog ... Don[   25.133000] Restarting system.
    ¦

    U-Boot 1.1.4.2-s445 (Sep  6 2010 - 14:46:33)

    Board: Ubiquiti Networks XM board (rev 0.0 e005)
    DRAM:  32 MB
    Flash:  8 MB
    N


    creo que el firm se pincho, intente por tftp y lo carga perfecto pero me hace lo mismo

    como puedo reparalo??? sera algun problema de hard???

    saludos
Accede o Regístrate para comentar.